<!DOCTYPE html><!-- HTML 5 -->
<html lang="en-US">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Port Royal Unveils Aggressive 2017 Schedule | Dirt Track Digest </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.dirttrackdigest.com/NewPress/xmlrpc.php" />

<!--[if lt IE 9]>
<script src="http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/js/html5shiv.min.js" type="text/javascript"></script>
<![endif]-->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//w.sharethis.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dirt Track Digest  &raquo; Feed" href="http://www.dirttrackdigest.com/NewPress/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Dirt Track Digest  &raquo; Comments Feed" href="http://www.dirttrackdigest.com/NewPress/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Dirt Track Digest  &raquo; Port Royal Unveils Aggressive 2017 Schedule Comments Feed" href="http://www.dirttrackdigest.com/NewPress/?feed=rss2&#038;p=28659" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.dirttrackdigest.com\/NewPress\/wp-includes\/js\/wp-emoji-release.min.js?ver=2a90281980b99d7963bbae07624b841b"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ssbaFont-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-stylesheet-css'  href='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/style.css?ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-genericons-css'  href='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/css/genericons/genericons.css?ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-flexslider-css'  href='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/css/flexslider.css?ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-text-font-css'  href='//fonts.googleapis.com/css?family=Droid+Sans&#038;ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-title-font-css'  href='//fonts.googleapis.com/css?family=Francois+One&#038;ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-navi-font-css'  href='//fonts.googleapis.com/css?family=Roboto&#038;ver=2a90281980b99d7963bbae07624b841b' type='text/css' media='all' />
<link rel='stylesheet' id='newsletter-subscription-css'  href='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/newsletter/subscription/style.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script id='st_insights_js' type='text/javascript' src='http://w.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/js/jquery.flexslider-min.js?ver=2a90281980b99d7963bbae07624b841b'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dynamicnews_slider_params = {"animation":"horizontal"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/js/slider.js?ver=2a90281980b99d7963bbae07624b841b'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/themes/dynamic-news/js/navigation.js?ver=2a90281980b99d7963bbae07624b841b'></script>
<link rel='https://api.w.org/' href='http://www.dirttrackdigest.com/NewPress/?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.dirttrackdigest.com/NewPress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.dirttrackdigest.com/NewPress/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Port Royal Welcomes New Division And Event Title Sponsors' href='http://www.dirttrackdigest.com/NewPress/?p=28656' />

<link rel="canonical" href="http://www.dirttrackdigest.com/NewPress/?p=28659" />
<link rel='shortlink' href='http://wp.me/p5B6Nu-7sf' />
<link rel="alternate" type="application/json+oembed" href="http://www.dirttrackdigest.com/NewPress/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.dirttrackdigest.com%2FNewPress%2F%3Fp%3D28659" />
<link rel="alternate" type="text/xml+oembed" href="http://www.dirttrackdigest.com/NewPress/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.dirttrackdigest.com%2FNewPress%2F%3Fp%3D28659&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.1.62" /> -->
<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									
								}
								</style><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.dirttrackdigest.com/NewPress/?wordfence_logHuman=1&hid=52F46CC8B89A6D19D2D2B3F55C43E90D');
</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
			#logo a:hover .site-title {
				color: #000000;
			}
			#navi-wrap, #social-icons-menu li a:hover {
				background-color: #000000;
			}
			#logo .site-title {
				color: #000cf2;
			}
			#mainnav-menu a:hover, #mainnav-menu ul a:hover, #mainnav-icon:hover, #social-icons-menu li a {
				background-color:  #000cf2;
			}
			.page-title, .post-title, .post-title a:link, .post-title a:visited, .archive-title span, 
			.postmeta a:link, .postmeta a:visited, #comments .comments-title, #respond #reply-title {
				color: #000000;
			}
			input[type="submit"]:hover, .more-link:hover, .postinfo .meta-category a, #commentform #submit:hover {
				background-color: #000000;
			}
			.page-title, .post-title, #comments .comments-title, #respond #reply-title {
				border-bottom: 5px solid #000000;
			}
			a, a:link, a:visited, .comment a:link, .comment a:visited, .archive-title span, 
			.post-title a:hover, .post-title a:active, .post-pagination a:link, .post-pagination a:visited {
				color: #1e73be;
			} 
			.postinfo .meta-category a:hover, .postinfo .meta-category a:active,
			.bypostauthor .fn, .comment-author-admin .fn, input[type="submit"], .more-link, #commentform #submit {
				background-color:  #1e73be;
			}
			#sidebar .widget a:link, #sidebar .widget a:visited {
				color: #1e73be;
			}
			.widget-tabnav li a, .widget-tabnav li a:link, .widget-tabnav li a:visited {
				color: #fff !important;
				background: #1e73be;
			}
			#frontpage-slider-wrap:hover .frontpage-slider-controls a:hover, .frontpage-slider-controls .zeeflex-control-paging li a.zeeflex-active {
				background-color:  #eade00;
			}
			#frontpage-slider .zeeslide .slide-entry {
				border-top: 10px solid #eade00;
			}
			#footer-widgets-bg, #footer-wrap {
				background-color: #363d45;
			}</style><style type="text/css">
			#mainnav-icon, #mainnav-menu a {
				font-family: "Roboto";
			}</style><style type="text/css">
			@media only screen and (min-width: 60em) {
				#content {
					float: right;
					padding-right: 0;
					padding-left: 1.5em;
				}
				#sidebar {
					float: left;
				}
			}
		</style><style type="text/css">
				@media only screen and (max-width: 60em) {
					#header-content { padding-top: 0; }
				}
				#header { padding: 0; }
		</style><script>
    (function (i, s, o, g, r, a, m) {
        i['GoogleAnalyticsObject'] = r;
        i[r] = i[r] || function () {
                (i[r].q = i[r].q || []).push(arguments)
            }, i[r].l = 1 * new Date();
        a = s.createElement(o),
            m = s.getElementsByTagName(o)[0];
        a.async = 1;
        a.src = g;
        m.parentNode.insertBefore(a, m)
    })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

    ga('create', 'UA-7458578-2', 'auto');
    ga('send', 'pageview');
</script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #000000; background-image: url("http:\/\/www.dirttrackdigest.com\/NewPress\/wp-content\/uploads\/2015\/01\/012515-FP-Background-2.png"); background-position: center top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Port Royal Unveils Aggressive 2017 Schedule" />
<meta property="og:url" content="http://www.dirttrackdigest.com/NewPress/?p=28659" />
<meta property="og:description" content="PORT ROYAL, PA – Port Royal Speedway has released an ambitious 31-date slate of racing events for the upcoming 2017 season. The schedule is filled with some of the biggest shows for stock cars and …" />
<meta property="article:published_time" content="2017-01-09T02:17:56+00:00" />
<meta property="article:modified_time" content="2017-01-09T02:17:56+00:00" />
<meta property="article:author" content="https://www.facebook.com/dirttrackdigest/" />
<meta property="og:site_name" content="Dirt Track Digest " />
<meta property="og:image" content="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="683" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@DirtTrackDigest" />
<meta name="twitter:image" content="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@DirtTrackDigest" />
<link rel="icon" href="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2015/04/DTD-HI-RES-552c4debv1_site_icon-32x32.png" sizes="32x32" />
<link rel="icon" href="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2015/04/DTD-HI-RES-552c4debv1_site_icon-256x256.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2015/04/DTD-HI-RES-552c4debv1_site_icon-256x256.png" />
<meta name="msapplication-TileImage" content="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2015/04/DTD-HI-RES-552c4debv1_site_icon.png" />

<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/wp-spamshield/js/jscripts.php'></script> 
</head>

<body class="post-template-default single single-post postid-28659 single-format-standard custom-background">


<div id="wrapper" class="hfeed">
	
	<div id="header-wrap">
	
		<header id="header" class="container clearfix" role="banner">

			<div id="logo" class="clearfix">
			
				<a href="http://www.ridefox.com/subhome.php?m=track&ref=topnav" title="Dirt Track Digest " rel="home">
								<img class="logo-image" src="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2016/09/DTD-VP-Header-NEW-2.jpg" alt="Logo"></img></a>
			
							</a>
				
						
			</div>
			
			<div id="header-content" class="clearfix">
							</div>

		</header>
	
	</div>
	
	<div id="navi-wrap">
		<nav id="mainnav" class="container clearfix" role="navigation">
			<h4 id="mainnav-icon">Menu</h4>
			<ul id="mainnav-menu" class="menu"><li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-51"><a href="http://www.dirttrackdigest.com/NewPress/">Home</a></li>
<li id="menu-item-53" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-53"><a href="#">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-49" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49"><a href="http://www.dirttrackdigest.com/NewPress/?cat=4">Exclusive Columnists</a></li>
	<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="http://www.dirttrackdigest.com/NewPress/?cat=5">Contributing Columnists</a></li>
</ul>
</li>
<li id="menu-item-16260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16260"><a href="http://www.dirttrackdigest.com/NewPress/?page_id=3946">Super Schedule</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55"><a href="#">Modifieds</a>
<ul class="sub-menu">
	<li id="menu-item-57" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57"><a href="http://www.dirttrackdigest.com/NewPress/?cat=3">Modified Tour News</a></li>
	<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="http://www.dirttrackdigest.com/NewPress/?cat=2">Modified Track News</a></li>
	<li id="menu-item-15417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15417"><a href="http://www.dirttrackdigest.com/NewPress/?page_id=15415">DIRTcar Nationals Recap</a></li>
	<li id="menu-item-143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143"><a href="http://www.dirttrackdigest.com/NewPress/?cat=24">Sportsman News</a></li>
	<li id="menu-item-452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-452"><a href="http://www.dirttrackdigest.com/NewPress/?cat=72">UMP/IMCA Modifieds</a></li>
</ul>
</li>
<li id="menu-item-58" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-58"><a href="#">Sprint Cars</a>
<ul class="sub-menu">
	<li id="menu-item-59" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59"><a href="http://www.dirttrackdigest.com/NewPress/?cat=7">National Sprint Car News</a></li>
	<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-60"><a href="http://www.dirttrackdigest.com/NewPress/?cat=8">Northeast Sprint Car News</a></li>
	<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-177"><a href="http://www.dirttrackdigest.com/NewPress/?cat=33">Non-Wing Sprint Car News</a></li>
	<li id="menu-item-3003" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3003"><a href="http://www.dirttrackdigest.com/NewPress/?cat=197">Micro/Mini Sprint News</a></li>
</ul>
</li>
<li id="menu-item-20218" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-20218"><a href="#">Late Models</a>
<ul class="sub-menu">
	<li id="menu-item-20219" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20219"><a href="http://www.dirttrackdigest.com/NewPress/?cat=11">National Late Model News</a></li>
	<li id="menu-item-20217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20217"><a href="http://www.dirttrackdigest.com/NewPress/?cat=454">Northeast Late Model News</a></li>
</ul>
</li>
<li id="menu-item-190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-190"><a href="#">Misc. News</a>
<ul class="sub-menu">
	<li id="menu-item-189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-189"><a href="http://www.dirttrackdigest.com/NewPress/?cat=35">Driver News</a></li>
	<li id="menu-item-2534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2534"><a href="http://www.dirttrackdigest.com/NewPress/?cat=182">Full Fender News</a></li>
	<li id="menu-item-144" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144"><a href="http://www.dirttrackdigest.com/NewPress/?cat=25">Indoor Racing</a></li>
	<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="http://www.dirttrackdigest.com/NewPress/?cat=14">Press Box</a></li>
</ul>
</li>
<li id="menu-item-61" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-61"><a href="http://www.dirttrackdigest.com/DTD">Forum</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62"><a href="http://www.dirttrackdigest.com/gallery7">Gallery</a></li>
<li id="menu-item-24624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24624"><a href="#">Special Events</a>
<ul class="sub-menu">
	<li id="menu-item-26951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26951"><a href="http://www.dirttrackdigest.com/SDWLIVE2">SDW 2016</a></li>
	<li id="menu-item-87" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87"><a href="http://www.dirttrackdigest.com/SDWLIVE/">SDW (Archive)</a></li>
	<li id="menu-item-24625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24625"><a href="http://www.dirttrackdigest.com/NewPress/?page_id=24423">Knoxville Nationals</a></li>
</ul>
</li>
</ul>		</nav>
	</div>
	
	
	<div id="wrap" class="container clearfix">
		
		<section id="content" class="primary" role="main">
		
<center>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-4317356775865659";
/* Forum Bottom Footer */
google_ad_slot = "7165656741";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</center>
<BR>
		
	<article id="post-28659" class="post-28659 post type-post status-publish format-standard has-post-thumbnail hentry category-northeast-sprint-car-news tag-port-royal">
	
		<h2 class="post-title">Port Royal Unveils Aggressive 2017 Schedule</h2>
		
		<div class="postmeta">		
		<span class="meta-date">
		<a href="http://www.dirttrackdigest.com/NewPress/?p=28659" title="2:17 am" rel="bookmark"><time datetime="2017-01-09T02:17:56+00:00">January 9, 2017</time></a>		</span>
		
		<span class="meta-author sep">
		<a href="http://www.dirttrackdigest.com/NewPress/?author=2" title="View all posts by Managing Editor" rel="author">Managing Editor</a>		</span>
		
		
	</div>
		
		<img width="800" height="534" src="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett-800x534.jpg" class="attachment-featured_image size-featured_image wp-post-image" alt="" srcset="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett-800x534.jpg 800w, http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett-300x200.jpg 300w, http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett-768x512.jpg 768w, http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2017/01/010817-Hodnett.jpg 1024w" sizes="(max-width: 800px) 100vw, 800px" />		
		<div class="entry clearfix">
			<p>PORT ROYAL, PA – Port Royal Speedway has released an ambitious 31-date slate of racing events for the upcoming 2017 season.</p>
<p>The schedule is filled with some of the biggest shows for stock cars and sprint cars to ever take place at the historic oval since auto racing began there in the late 1930s.</p>
<p>The 2017 season gets underway with the season opener on Saturday, March 11 with a twin bill of Weikert’s Livestock 410 sprints and River Valley Builders super late models.</p>
<p>Two more two-division shows round out the month of March while all three shows offer a 5 pm starting time.</p>
<p>In total, 29 of the 31 dates feature 410 sprints cars while 21 events include the super late models.</p>
<p>Also back for regular action in 2017 will be the Gray’s Auto and Towing 355 econo late models, the Juniata Junction xtreme stocks and the Creasy Signs 305 sprint series.</p>
<p>News has already been broken regarding the biggest events of the season for the 410 sprints and the super late models.</p>
<p>For the late models, must see events include the first appearance in Central Pennsylvania by the Lucas Oil Dirt Late Model Challenge Series paying $10,000 to win on Sunday, April 23 followed up by a $10,000 to win World of Outlaws late model program on Saturday, August 19.</p>
<p>Other big late model events include Late Model Speedweek June 3, the Fallen Heroes Championship May 27, the Butch Renninger UFO Late Model Memorial on September 2 to kick off the Juniata County Fair and the first show of the year for the UFO series on March 25.</p>
<p>And back for a second season in 2017 is the Moon Shine Camo Rt. 35 Port Royal/Selinsgrove Speedway Late Model Challenge Series with Port Royal dates paying $2,000 to win slated for April 29, July 8 and September 8 with the September program again crowing the six-date, dual-track series champion.</p>
<p>Sanctioned by Tony Stewart’s Arctic Cat All Star Circuit of Champions Sprints, the 50th annual Tuscarora 50 on September 9 will be celebrated in a huge way with a $50,000 to win event offering a total purse of some $100,000 to make it the richest and biggest event of all-time at the Juniata County oval.</p>
<p>The Arctic Cat All Stars will also sanction the Night Before The 50 on September 8 and the second running of the Keith Kauffman Classic on Saturday, April 29.</p>
<p>The USAC 410 sprints will again appear at the track in 2017 this time joined by the regular Port Royal 410 sprints for a fantastic sprint car spectacular on June 17.</p>
<p>The Packer’s Concessions Bob Weikert Memorial for 410 sprints weekend is slated for Saturday and Sunday, May 27 and 28 with the super late models joining the fun on Saturday and the URC 360 sprints on the program for the Sunday finale.</p>
<p>The Weikert Memorial sprints will vie for $5,000 to win on Saturday and $10,000 to win on Sunday night.</p>
<p>Other big sprint car shows of note include two PA Speedweek events at the track again in 2017, coming on Thursday, July 6 and on Saturday, July 8. The Living Legends Dream Race has a new date this season, slated for July 29.</p>
<p>The month of October sees the World of Outlaws sprint cars return for a one-day stand on Saturday, October 14 followed by the season finale Open Wheel Madness program of 410 sprints, URC 360 sprints and 305 sprints on October 21.</p>
<p>Highlights for the 305 sprint series at the track in 2017 include the make-up of the 2016 Keystone RaceSaver Blue Collar Classic on April 22 and the 2017 installment on October 7.</p>
<p>Both the econo late models and the xtreme stocks will compete as usual during the season with a few races for each division carrying increased purses including a $1,200 to win event for econo lates billed as the Dave Kepner Tribute in July.</p>
<p>The full schedule of events will be posted on the speedway’s official website, portroyalspeedway.com, in the very near future.</p>
<p>Stay up to date with all Port Royal news and information by visiting the oval’s official website at www.portroyalspeedway.com or by following the track on Facebook or Twitter.</p>
<!-- Simple Share Buttons Adder (6.3.4) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left">It's only fair to share...<a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=http://www.dirttrackdigest.com/NewPress/?p=28659"  target="_blank" ><img src="http://www.dirttrackdigest.com/NewPress/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=http://www.dirttrackdigest.com/NewPress/?p=28659&amp;text=Port+Royal+Unveils+Aggressive+2017+Schedule+"  target="_blank" ><img src="http://www.dirttrackdigest.com/NewPress/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a></div></div>			<!-- <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.dirttrackdigest.com/NewPress/?p=28659"
    dc:identifier="http://www.dirttrackdigest.com/NewPress/?p=28659"
    dc:title="Port Royal Unveils Aggressive 2017 Schedule"
    trackback:ping="http://www.dirttrackdigest.com/NewPress/wp-trackback.php?p=28659" />
</rdf:RDF> -->
			<div class="page-links"></div>			
		</div>
		
		<div class="postinfo clearfix">			<span class="meta-tags">
				tagged with <a href="http://www.dirttrackdigest.com/NewPress/?tag=port-royal" rel="tag">Port Royal</a>			</span>
	
		<span class="meta-category">
			<ul class="post-categories">
	<li><a href="http://www.dirttrackdigest.com/NewPress/?cat=8" rel="category">Northeast Sprint Car News</a></li></ul>		</span>

	</div>

	</article>			
<BR>
<div style="text-align: center; " data-id="28026" id="dirtt-1246642423"><center>
<script language="JavaScript"> 
images = new Array(3);

images[0] = "<a href = 'http://www.ridefox.com/subhome.php?m=track&ref=topnav' rel='nofollow'><img src='http://dirttrackdigest.com/ads/FoxAdBig.jpg' border='0' height='100px' width='728px'></a>";
  
images[1] = "<a href = 'http://www.vpracingfuels.com/' rel='nofollow'><img src='http://www.dirttrackdigest.com/ads/VP-Large.jpg' border='0' height='100px' width='728px'></a>";
  
images[2] = "<a href = 'https://www.dirtondirt.com/liveOrder.php?id=47' rel='nofollow'><img src='http://www.dirttrackdigest.com/ads/DirtOnDirt-Big.jpg' border='0' height='100px' width='728px'></a>";
 
index = Math.floor(Math.random() * images.length); 
document.write(images[index]); 
</script>
</center>
<BR></div>

		

		
		</section>


		<section id="sidebar" class="secondary clearfix" role="complementary">

		<aside id="text-2" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Our Marketing Partners</span></h3>			<div class="textwidget"><center><a target="_blank" href="http://www.dirtondirt.com">
<img border="0" src="http://www.dirttrackdigest.com/ads/DirtonDirtSmall.jpg" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://www.bicknellracingproducts.com/bicknell_new/"><img src="http://www.dirttrackdigest.com/ads/Bicknell2015-YELLOW.jpg" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://www.ridefox.com/subhome.php?m=track&ref=topnav">
<img border="0" src="http://www.dirttrackdigest.com/ads/FoxAd_S.jpg" width="100%" height="94"></a></center>

<center><td align="center"> <a target="_blank" href="http://www.teopro.com/">
<img border="0" src="http://www.dirttrackdigest.com/ads/TeoProCar.gif" width="100%" height="94"></a></td></center>

<center><a target="_blank" href="https://www.facebook.com/pages/Fastline-Performance-Extreme-Speed-and-Performance/681211478604438?ref=br_tf"><img src="http://www.dirttrackdigest.com/ads/FastLineSmall.jpg" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://www.bobhilbert.com">
<img border="3" src="http://www.dirttrackdigest.com/ads/dtd8-12.gif" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://keizerwheels.com/">
<img border="3" src="http://www.dirttrackdigest.com/ads/KeizerWheels.jpg" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://ransomvillespeedway.com/">
<img border="3" src="http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2016/04/Ransomville-Ad.jpg
" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://www.vpracingfuels.com/">
<img border="0" src="http://www.dirttrackdigest.com/ads/VP-Small.jpg" width="100%" height="94"></a></center>

<a href = 'http://www.keysermanufacturing.com' rel='nofollow' ><img src='http://www.dirttrackdigest.com/ads/Integra.gif' border='0' height='94px' width='100%'></a>

<a href = ' http://www.outlawspeedwayllc.com/'><img src=' http://www.dirttrackdigest.com/NewPress/wp-content/uploads/2016/05/OutlawAd.jpg ' border='0' height='94px' width='100%'></a>

<a target="_blank" href = "http://www.wilkinsrv.com/"><img src=' http://www.dirttrackdigest.com/ads/WilkinsSmall.jpg' border='0' height='94px' width='100%'></a>

<a href = ' http://www.rocmodifiedseries.com/'><img src=' http://www.dirttrackdigest.com/ads/RaceofChampions1.jpg' border='0' height='94px' width='100%'></a>

<a href = ' http://www.uticaromespeedway.com/'><img src=' http://www.dirttrackdigest.com/ads/Utica-RomeAd.jpg' border='0' height='94px' width='100%'></a>

<center><a href="http://www.bdmotorsportsmedia.com" target="_blank"><img src="http://www.dirttrackdigest.com/ads/ShortTrackSmall.jpg" width="100%" height="94"></a></center>

<center><a target="_blank" href="http://www.pavedtrackdigest.com"> <img border="0" src="http://www.dirttrackdigest.com/ads/PTDAD1.jpg" width="100%"></a></center>

<center><a href="https://play.google.com/store/apps/details?id=com.andromo.dev202035.app191667&feature=nav_result#?t=W251bGwsMSwyLDNd" target="_blank"><img src="http://www.dirttrackdigest.com/ads/app-ad.jpg" width="100%" height="94" border="0"></a><br></center>
</div>
		</aside><aside id="text-3" class="widget widget_text clearfix">			<div class="textwidget"><center> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- auto size -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4317356775865659"
     data-ad-slot="2605764743"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

</center></div>
		</aside><aside id="text-5" class="widget widget_text clearfix">			<div class="textwidget"><center>

<a class="twitter-timeline" href="https://twitter.com/DTDMike" data-widget-id="307934597948248064">Tweets by @DTDMike</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

</center></div>
		</aside><aside id="text-6" class="widget widget_text clearfix"><h3 class="widgettitle"><span>Contact Us</span></h3>			<div class="textwidget">Mike Mallett (Managing Editor)
<BR>
<font size="2pt">
<a href="m&#x61;i&#x6c;&#x74;o&#x3a;m&#105;&#x6b;e&#x6d;a&#108;&#x6c;e&#x74;t&#64;&#x64;i&#x72;&#x74;t&#x72;a&#99;&#x6b;d&#x69;g&#101;&#x73;t&#x2e;c&#111;&#x6d;?subject=Dirt Track Digest">
M&#105;&#x6b;&#x65;M&#97;&#x6c;&#x6c;e&#116;&#x74;&#x40;di&#x72;&#x74;tr&#x61;&#x63;kd&#105;&#x67;&#x65;s&#116;&#x2e;&#x63;o&#109;</a> <BR></font>
(845) 461-5151
<BR><BR>
George Smith (Co-Owner)
<BR>
<a href="&#x6d;&#x61;il&#x74;&#x6f;&#58;ou&#x74;&#x6c;aw&#x40;&#x64;&#105;rt&#x74;&#x72;ac&#x6b;&#x64;&#105;ge&#x73;&#x74;&#46;c&#x6f;&#x6d;?subject=Dirt Track Digest">
&#79;&#x75;&#116;&#x6c;&#97;&#x77;&#64;&#x64;i&#x72;t&#x74;r&#x61;c&#x6b;d&#x69;g&#x65;s&#x74;.&#99;&#x6f;&#109;</a> <BR>

</div>
		</aside><aside id="search-3" class="widget widget_search clearfix">
	<form role="search" method="get" class="search-form" action="http://www.dirttrackdigest.com/NewPress/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s">
		</label>
		<button type="submit" class="search-submit">
			<span class="genericon-search"></span>
		</button>
	</form>

</aside>
	</section>	</div>


	

	

	<div id="footer-wrap">
	
		<footer id="footer" class="container clearfix" role="contentinfo">
			
			<nav id="footernav" class="clearfix" role="navigation">
								<h4 id="footernav-icon"></h4>
			</nav>
			
			<div id="footer-text">
			
			Copyright © 2016. Dirt Track Digest Motorsports Media. All Rights Reserved. Site Maintained by Dirt Track Digest Motorsports Media.				<span class="credit-link"></span>
			
			</div>
			
		</footer>
		
	</div>

</div><!-- end #wrapper -->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201702'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=2a90281980b99d7963bbae07624b841b'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/jetpack/modules/wpgroho.js?ver=2a90281980b99d7963bbae07624b841b'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/newsletter/subscription/validate.js?ver=4.7.5'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-content/plugins/wp-spamshield/js/jscripts-ftr-min.js'></script>
<script type='text/javascript' src='http://www.dirttrackdigest.com/NewPress/wp-includes/js/wp-embed.min.js?ver=2a90281980b99d7963bbae07624b841b'></script>

<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='8cec23aab11e715346933e658395267c';
hf4V='ccfc4f5dc27d81ae55dd1f6cffa10df5';
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(e);return true;});$("#comment").attr({minlength:"15",maxlength:"15360"})});
/* ]]> */
</script> 
	<div style="display:none">
	</div>
<script type='text/javascript' src='http://stats.wp.com/e-201702.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'82725948',post:'28659',tz:'0',srv:'www.dirttrackdigest.com'} ]);
	_stq.push([ 'clickTrackerInit', '82725948', '28659' ]);
</script>
        <script type="text/javascript">
            function AI_responsive_widget() {
                jQuery('object.StefanoAI-youtube-responsive').each(function () {
                    jQuery(this).parent('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    jQuery(this).children('.fluid-width-video-wrapper').removeClass('fluid-width-video-wrapper').removeAttr('style').css('width', '100%').css('display', 'block');
                    var width = jQuery(this).parent().innerWidth();
                    var maxwidth = jQuery(this).css('max-width').replace(/px/, '');
                    var pl = parseInt(jQuery(this).parent().css('padding-left').replace(/px/, ''));
                    var pr = parseInt(jQuery(this).parent().css('padding-right').replace(/px/, ''));
                    width = width - pl - pr;
                    if (maxwidth < width) {
                        width = maxwidth;
                    }
                    jQuery(this).css('width', width + "px");
                    jQuery(this).css('height', width / (16 / 9) + "px");
                    jQuery(this).find('iframe').css('width', width + "px");
                    jQuery(this).find('iframe').css('height', width / (16 / 9) + "px");
                });
            }
            if (typeof jQuery !== 'undefined') {
                jQuery(document).ready(function () {
                    var tag = document.createElement('script');
                    tag.src = "https://www.youtube.com/iframe_api";
                    var firstScriptTag = document.getElementsByTagName('script')[0];
                    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
                    AI_responsive_widget();
                });
                jQuery(window).resize(function () {
                    AI_responsive_widget();
                });
            }
                </script>
        </body>
</html>	